Issue with processing of paper postal invoices
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted May 17, 2024 - 15:15 CEST
Monitoring
The issue has been identified, and we implemented a fix. We are monitoring whether we get the desired results.
Posted May 17, 2024 - 12:17 CEST
Investigating
Due to an issue with a 3rd party provider we cannot ensure correct processing of paper postal invoices. We are contacting them as we speak.
Posted May 17, 2024 - 09:10 CEST
This incident affected: Teamleader Focus Web App.