Contact forms unavailable due to expired certificate
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 15:43 CET
Monitoring
We were able to update the certificate and are monitoring the results
Posted Jan 18, 2024 - 13:38 CET
Investigating
https://meeting.teamleader.eu/ is unavailable due to an expired certificate, we are investigating the cause and will get back to you asap
Posted Jan 18, 2024 - 13:09 CET
This incident affected: Cloud Platforms (Lead Capture Booster).