Unable to download files from Teamleader Focus in Google Chrome and Firefox

Incident Report for Teamleader

Resolved

This incident has been resolved.
Posted Jun 30, 2022 - 09:45 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2022 - 16:53 CEST

Identified

We identified the issue on our end and are currently implementing a fix.
Posted Jun 29, 2022 - 15:09 CEST

Investigating

We noticed there is an issue when downloading files from Teamleader Focus. Downloaded files are marked as suspicious and the user is unable to open the file. We're investigating the cause and will provide an update as soon as possible.
Posted Jun 29, 2022 - 10:15 CEST
This incident affected: Teamleader Focus Web App.