Power outage
Incident Report for Teamleader
Resolved
The power outage is now over so you can reach us again via all channels.
We are sorry for the inconvenience caused and thank you for your patience.
Posted May 15, 2019 - 16:22 CEST
Identified
Due to a power outage in the entire building, we have no internet connection and hence can't assist you at this point in time via call or via e-mail. We hope this will be solved quickly.

We are sorry for the inconvenience.
Posted May 15, 2019 - 15:31 CEST