Not available via phone

Incident Report for Teamleader

Resolved

After some technical issues, we are available again via phone.
We are sorry for the inconvenience.
Posted Aug 06, 2019 - 13:40 CEST

Identified

Due to technical issues, we are not available via phone at the moment.
We are sorry for this inconvenience and will let you know when we are available again.
Posted Aug 06, 2019 - 08:51 CEST

Investigating

Due to technical issues, we are not available via phone at the moment.
We are sorry for this inconvenience and will let you know when we are available again.
Posted Aug 05, 2019 - 13:35 CEST