Teamleader Focus - Customer Meeting Add-On Service Disruption
Incident Report for Teamleader
Resolved
Our team has identified and resolved the issue. All systems are operational.
Posted Oct 28, 2023 - 17:37 CEST
Identified
We are currently experiencing a service disruption for the Customer Meeting Add-On. Our development team has identified the root cause and is implement a solution. We will provide an update as soon as the issue evolves.
Posted Oct 28, 2023 - 16:10 CEST
This incident affected: Teamleader Focus Web App, Teamleader Focus Mobile App and Cloud Platforms (Lead Capture Booster).