Teamleader down
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 15:11 CEST
Monitoring
Loading times are back to normal, we are further monitoring.
Posted Oct 09, 2023 - 10:47 CEST
Investigating
The following modules are currently unavailable: deals, quotations, projects, work orders, timesheets.

We are currently investigating the issue and will post updates soon.
Posted Oct 09, 2023 - 10:35 CEST
This incident affected: Teamleader Focus Web App, Teamleader Focus Mobile App and Teamleader Focus components (Deals, Projects, Work orders, Timesheets).