Teamleader slowness
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 14:34 CET
Monitoring
Teamleader is fully functional again and we are monitoring the results.
Posted Feb 01, 2021 - 16:58 CET
Update
We are continuing to investigate this issue.
Posted Feb 01, 2021 - 16:00 CET
Update
We are continuing to investigate this issue.
Posted Feb 01, 2021 - 15:20 CET
Investigating
We are experiencing slowness and we are investigating this as we speak. We will come back to you with an update within 30 minutes.

We are sorry for the inconvenience and we thank you for your patience.
Posted Feb 01, 2021 - 15:17 CET
This incident affected: Teamleader.