Teamleader Focus Service Disruption: Some emails are not being delivered
Incident Report for Teamleader
Resolved
Our development team has resolved the issue. We will keep a close eye if further issues may occur. We thank you for your patience.

Emails that were blocked earlier today, can be found in the email log in your Temaleader Focus account (https://focus.teamleader.eu/email-log.php). We advise you to send these emails again to your correspondent. All emails are now being delivered properly.

If you have any questions, you can contact our support team via the following link: https://support.teamleader.eu/en/support/tickets/new
Posted Jun 09, 2022 - 17:03 CEST
Update
All new emails that are being sent from Teamleader Focus are now being delivered properly..
Emails that were blocked before can be found in the email log in your Temaleader Focus account (https://focus.teamleader.eu/email-log.php). We advise you to send these emails again to your correspondent.

If you have any questions, you can contact our support team via the following link: https://support.teamleader.eu/en/support/tickets/new
Posted Jun 09, 2022 - 14:16 CEST
Monitoring
we have implemented a fix and we are monitoring the results. All new emails that are being sent from Teamleader Focus are now being delivered properly. We're still investigating a way to process the previously blocked emails.
Posted Jun 09, 2022 - 13:25 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2022 - 13:06 CEST
Identified
We noticed some of the emails sent via Teamleader Focus are not being delivered (including Teamleader Focus notifications). We're investigating the cause and will provide an update as soon as possible.
Posted Jun 09, 2022 - 13:05 CEST
This incident affected: Teamleader Focus Web App and API and integration services (Upstream providers).