Teamleader Focus service disruption - invoice cloud
Incident Report for Teamleader
Resolved
Our development team implemented a fix and has resolved the issue. All invoices should now be available again on the Invoicecloud. We will keep a close eye if further issues may occur. We thank you for your patience.

If you are still experiencing issues you can contact our support team via the following link: https://support.teamleader.eu/en/support/tickets/new
Posted Dec 17, 2021 - 14:26 CET
Identified
We have identified a service disruption in Teamleader Focus. Invoices are not available anymore on the invoice cloud.
Our development team is working to identify the root cause and implement a solution.

We will provide an update as soon as the issue evolves.
Posted Dec 17, 2021 - 13:52 CET
This incident affected: Teamleader Focus Web App and Cloud Platforms (Invoicecloud).