Teamleader Focus slow
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted May 23, 2023 - 09:44 CEST
Monitoring
Monitoring: we have implemented a fix and we are monitoring the results.
Posted May 22, 2023 - 17:31 CEST
Investigating
Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted May 22, 2023 - 17:20 CEST
This incident affected: Teamleader Focus Web App.