Teamleader Focus slow
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 14:41 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2023 - 10:16 CEST
Investigating
Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Jun 14, 2023 - 09:35 CEST
This incident affected: Teamleader Focus Web App.