Teamleader Focus slow

Incident Report for Teamleader

Resolved

This incident has been resolved.
Posted Sep 28, 2022 - 08:49 CEST

Monitoring

We have implemented a fix and we are monitoring the results.
Posted Sep 27, 2022 - 16:53 CEST

Investigating

Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Sep 27, 2022 - 14:36 CEST
This incident affected: Teamleader Focus Web App and Teamleader Focus Mobile App.