Teamleader Focus - Degraded performance
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Dec 09, 2024 - 12:35 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2024 - 10:42 CET
Investigating
Teamleader Focus is currently experiencing technical difficulties and may be causing certain pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Dec 09, 2024 - 09:11 CET
This incident affected: Teamleader Focus Web App.