Teamleader slow

Incident Report for Teamleader

Resolved

We were able to identify the root cause and Teamleader is up and running again.

If you would notice any further problems please let us know via support@teamleader.eu
Posted Oct 22, 2019 - 11:20 CEST

Investigating

We are experiencing slowness and we are investigating this as we speak. We will try to come back with an update in 30 minutes.

We are sorry for the inconvenience and we thank you for your patience.
Posted Oct 22, 2019 - 10:35 CEST
This incident affected: Teamleader Focus Web App.