Some invoices were sent out multiple times
Incident Report for Teamleader
Resolved
We have been monitoring this incident for a few days and were also able to resolve all issues caused by this issue. If any other issues would occur please contact us via support@teamleader.eu
We thank you for your patience and we are sorry for the inconvenience.
Posted May 09, 2019 - 09:30 CEST
Monitoring
We were able to implement a fix for the issue of the multiple creations of invoices.
We will be monitoring the situation for now. If you would be affected again by this issue please contact us immediately via support@teamleader.eu
Thank you for your patience!
Posted May 02, 2019 - 18:20 CEST
Investigating
Certain invoices and reminders were sent out twice overnight. We're looking into the issue and we will keep you posted on the status and possible actions required, but if you are affected, please contact our support team (support@teamleader.eu). Our sincerest apologies for the inconvenience!
Posted May 01, 2019 - 10:51 CEST