Teamleader Focus slow

Incident Report for Teamleader

Resolved

This incident has been resolved.
Posted Aug 10, 2023 - 07:28 CEST

Monitoring

Monitoring: we have implemented a fix and we are monitoring the results.
Posted Aug 09, 2023 - 10:43 CEST

Investigating

Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Aug 09, 2023 - 09:55 CEST
This incident affected: Teamleader Focus Web App.