Teamleader Focus Service Disruption
Incident Report for Teamleader
Resolved
Our development team has resolved the issue. Your data should be visible again in Teamleader Focus. No data was lost. We will keep a close eye if further issues may occur. We thank you for your patience.

If you are still experiencing issues you can contact our support team via the following link: https://support.teamleader.eu/en/support/tickets/new
Posted Jul 13, 2022 - 20:46 CEST
Investigating
We notice a general malfunction in Teamleader Focus due to a mistake in a planned update operation. We assure you no data is lost. We're investigating the issue as we speak and will provide an update as soon as possible.
Posted Jul 13, 2022 - 20:33 CEST
This incident affected: Teamleader Focus Web App.