Email delivery delayed
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 09:04 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 10, 2023 - 09:04 CET
Monitoring
We have implemented a fix and we are monitoring the results.
Posted Mar 09, 2023 - 14:50 CET
Update
We are continuing to investigate the issue and are still in contact with our email provider to get it fixed ASAP.
Posted Mar 09, 2023 - 11:50 CET
Investigating
Emails sent since 8h20 (CET) this morning are delayed. We're investigating the cause together with our email provider and will give an update as soon as possible. You can keep on sending emails, but they will only be delivered once the issue has been solved.
Posted Mar 09, 2023 - 09:55 CET
This incident affected: Teamleader Focus Web App.