Slower response time
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 15:34 CET
Monitoring
We were able to fix the issue. We will be monitoring the situation for further issues.

Thank you for bearing with us and we are sorry for the inconvenience.
Posted Feb 26, 2021 - 10:42 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 26, 2021 - 10:02 CET
Identified
We are noticing Teamleader is experiencing a slower response time.
Our team is investigating this issue. We will try to be back with an update in 30 minutes.

We are sorry for the inconvenience this may cause and we thank you for your patience.
Posted Feb 26, 2021 - 10:02 CET
This incident affected: Teamleader Focus Web App.