Slowness in Teamleader Focus

Incident Report for Teamleader

Resolved

The slowness issue has been tackled and resolved. Thank you for your patience and understanding.
Posted Oct 01, 2025 - 10:58 CEST

Monitoring

We have identified the issue, implemented a fix and are currently monitoring the results.
Posted Sep 30, 2025 - 16:41 CEST

Investigating

The issue of slowness in Teamleader Focus has come up again. We are investigating the cause and will keep you updated.
Posted Sep 30, 2025 - 11:14 CEST

Monitoring

We have identified the issue, implemented a fix and are currently monitoring the results.
Posted Sep 29, 2025 - 17:20 CEST

Investigating

We are currently investigating this issue and will update you as soon as we have more information.
Posted Sep 29, 2025 - 10:17 CEST
This incident affected: Teamleader Focus Web App.