Degraded performance
Incident Report for Teamleader
Resolved
And just like that
Posted Apr 21, 2020 - 01:26 CEST
Monitoring
A database maintenance operation is taking longer than expected and could cause Teamleader to be less responsive. We're keeping a close eye on the progress of the operation in order to keep the inconveniences to a minimum.
Posted Apr 21, 2020 - 01:17 CEST
This incident affected: Teamleader Focus Web App.