The incident has been marked as resolved by Microsoft after an extensive monitoring. Everything regarding the Exchange Web Services and the Outlook upstream provider is working as expected.
Posted Nov 28, 2024 - 09:13 CET
Monitoring
The issues with the Exchange Web Services and the Outlook upstream provider seem to have been resolved for the time being, we're monitoring the situation; our services are operational again.
Posted Nov 26, 2024 - 08:55 CET
Identified
The issue has been identified and confirmed by our 3rd party provider Microsoft. Microsoft is currently deploying and monitoring a fix which should resolve the issue shortly.
Posted Nov 25, 2024 - 16:11 CET
Update
We are continuing to investigate this issue.
Posted Nov 25, 2024 - 12:05 CET
Investigating
There are currently issues with the Exchange Web Services and the Outlook upstream provider, which might impact our Outlook integrations. We are currently monitoring the situation to make sure that these services can be restored as soon as possible once available again.
Posted Nov 25, 2024 - 09:42 CET
This incident affected: Cloud Platforms (Lead Capture Booster) and API and integration services (Exchange Web Services, Upstream providers).