Teamleader unavailable
Incident Report for Teamleader
Resolved
The issue has been resolved. We thank you for your patience.
If you are still experiencing issues please contact support@teamleader.eu
Thank you for your patience.
Posted Dec 10, 2019 - 09:06 CET
Monitoring
We were able to fix the issue. We will be monitoring the situation for further issues.
Thank you for bearing with us and we are sorry for the inconvenience.
Posted Dec 09, 2019 - 17:03 CET
Identified
Teamleader is unavailable right now. We are working on a fix.
We thank you for your patience
Posted Dec 09, 2019 - 16:50 CET
This incident affected: Teamleader Focus Web App.