Teamleader Focus slow
Incident Report for Teamleader
Resolved
Our development team has resolved the issue. We will keep a close eye if further issues may occur. We thank you for your patience.
Posted Jan 18, 2023 - 10:00 CET
Monitoring
We have implemented a fix and we are monitoring the results.
Posted Jan 17, 2023 - 16:27 CET
Identified
Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Jan 17, 2023 - 16:09 CET
This incident affected: Teamleader Focus Web App.