Teamleader Focus is currently unavailable

Incident Report for Teamleader

Resolved

Our development team has resolved the issue. We will keep a close eye if further issues may occur. We thank you for your patience.
Posted Oct 14, 2025 - 17:08 CEST

Update

We are continuing to monitor for any further issues.
Posted Oct 14, 2025 - 15:55 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2025 - 15:19 CEST

Update

We are continuing to investigate this issue.
Posted Oct 14, 2025 - 14:42 CEST

Investigating

Teamleader Focus is currently unavailable

We are trying to resolve this as soon as possible.
Posted Oct 14, 2025 - 14:41 CEST
This incident affected: Teamleader Focus Web App.