Teamleader slowness
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 15:24 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2021 - 12:26 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 15, 2021 - 12:11 CET
Investigating
We are experiencing slowness and we are investigating this as we speak. We will come back to you with an update within 30 minutes.

We are sorry for the inconvenience and we thank you for your patience.
Posted Feb 15, 2021 - 12:06 CET
This incident affected: Teamleader Focus Web App.