Teamleader slowness
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 17:27 CET
Monitoring
We have implemented a fix and Teamleader is fully functional again. We'll keep monitoring the results.

We thank you for your patience
Posted Feb 25, 2021 - 15:10 CET
Identified
We have identified the issue and are working towards a solution.

We are very sorry about this inconvenience and we thank you for your patience.
Posted Feb 25, 2021 - 14:54 CET
Update
We are continuing to investigate this issue.
Posted Feb 25, 2021 - 14:43 CET
Investigating
We are experiencing slowness and we are investigating this as we speak. We will come back to you with an update within 30 minutes.

We are sorry for the inconvenience and we thank you for your patience.
Posted Feb 25, 2021 - 14:37 CET
This incident affected: Teamleader, API and Cloud Platforms (Invoicecloud, Ticketcloud, Cloudproject, Cloudsign).