Issue with logging in via website
Incident Report for Teamleader
Resolved
We have resolved the login issue.

If you have any questions regarding this incident, don't hesitate to contact us via support@teamleader.eu. Thank you for your patience.
Posted May 07, 2019 - 09:44 CEST
Identified
We have identified an issue with logging in and we are working on a fix to solve this.
For now you can use app.teamleader.eu to login. We will come back to you in a half an hour with an update
We are sorry for this inconvenience and thank you for your patience.
Posted May 07, 2019 - 09:09 CEST