Current delay in the insights module and legacy shared inbox stats

Incident Report for Teamleader

Resolved

This incident has been resolved. We thank you again for your understanding!
Posted Oct 31, 2025 - 08:59 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 13:18 CET

Identified

The data of the insights and shared inbox statistics have not been refreshing since October 29, 2025, 11:25 (UTC+01:00). We have found the cause and are already working on it. Thank you for your patience and understanding.
Posted Oct 30, 2025 - 10:27 CET
This incident affected: Teamleader Focus components (Shared inbox, Insights).