Teamleader Focus slow
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Oct 26, 2022 - 09:03 CEST
Update
We are continuing to monitor for any further issues.
Posted Oct 25, 2022 - 17:13 CEST
Monitoring
The slowness is under control, and we are putting measures in place in order to prevent further hiccoughs.
Posted Oct 25, 2022 - 12:15 CEST
Investigating
Teamleader Focus is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. Our development team is investigating the cause and we will provide an update as soon as the issue evolves.
Posted Oct 25, 2022 - 11:17 CEST
This incident affected: Teamleader Focus Web App.