Not available via phone
Incident Report for Teamleader
Resolved
We were able to activate the power again so we are now available again via phone.
Thank you for your patience.
Posted Jul 04, 2019 - 13:25 CEST
Identified
Due to a power outage, we are not available via phone at the moment.
We are sorry for this inconvenience and will let you know when we are available again.
Posted Jul 04, 2019 - 12:27 CEST