Some invoices are not available through Invoicecloud
Incident Report for Teamleader
Resolved
After carefully monitoring the situation we don't see any further issues.

We thank you for your patience.
Posted Jul 24, 2020 - 22:58 CEST
Monitoring
We were able to fix the issue and everything should be working correctly again.
If not, please contact support@teamleader.eu
We will be monitoring the situation for the next hour.
We thank you for your patience and we are sorry for the inconvenience.
Posted Jul 24, 2020 - 19:52 CEST
Identified
We have identified the issue and are working on fixing the problem. Thank you for bearing with us.
We are sorry for the inconvenience.
Posted Jul 24, 2020 - 18:41 CEST
Investigating
We are investigating an issue where invoices are not available through Invoicecloud. We'll come back to you as soon as we have an update.

We are sorry for the inconvenience.
Posted Jul 24, 2020 - 18:09 CEST
This incident affected: Cloud Platforms (Invoicecloud).