Invoice detail page issue
Incident Report for Teamleader
Resolved
We've found and fixed the issue with the invoice detail page issue. It's possible to open and book invoices again. Thanks for your patience!
Posted Apr 20, 2018 - 16:05 CEST
Investigating
We're noticing an issue with opening and/or booking invoices. We're looking into the issue and will be back to you shortly. Our apologies for the inconvenience.
Posted Apr 20, 2018 - 15:50 CEST