Automatic credit refill issue (Twilio)
Incident Report for Teamleader
Postmortem

Dear customer,

Earlier today we noticed a problem with Twilio. Some of you were suddenly unable to call via Voice over IP anymore. After some investigation we found the cause of the problem: the automatic refill of credits was not working properly anymore.

After some more investigation we found the cause of this problem. Twilio suddenly stopped billing us anymore, which in return led to us not billing you (automatically) anymore. This led to a build up of uncharged costs in Twilio numbers and calls. Due to a fix of this problem, the charges for the phone numbers were executed again, which caused the credits cards to be charged suddenly. This led to a drop in credits, which caused the unavailability to call via Voice over IP.

Once we found the cause of the problem, we fixed this issue as soon as possible. We managed to refill the wallet of most of our customers, but this did not work for everyone. If you still experience issues, we recommend to do a manual refill of your Teamleader wallet.

We know this problem caused you a lot of inconvenience. We know and we care. We want to do something in return: only the costs for your Twilio numbers will be charged from your credit card.

We hope to have informed you well enough. If you do have anymore questions, do not hesitate to reach out to support@teamleader.eu.

Posted Oct 06, 2017 - 18:48 CEST

Resolved
We've resolved the issue with the automatic credit refill for Twilio. The credits have been topped up and it's possible to call via VoIP again. If you still encounter errors, you can also manually top up your credits via the Teamleader licence page (only accessible by admins). Happy calling and enjoy the weekend!
Posted Oct 06, 2017 - 11:27 CEST
Investigating
We are investigating an issue with the automatic credit refill for Twilio (VoIP). Because the credits were not automatically refilled, calling via VoIP might be temporarily unavailable. We are currently working on a solution. We apologise for the inconvenience.
Posted Oct 06, 2017 - 10:12 CEST