Syncing problems with Microsoft Exchange
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Dec 02, 2016 - 14:26 CET
Monitoring
We applied fixes for all discovered issues.

We are confident that all issues are resolved now and are monitoring closely.
In case your account still show issues, feel free to contact support so we can further investigate.
Posted Dec 01, 2016 - 15:26 CET
Update
We found a timeout issue in the protocol towards specific versions of Exchange servers

This appeared to be the biggest remaining issue in the Exchange integration.
Posted Dec 01, 2016 - 15:24 CET
Identified
We identified different smaller issues with the Exchange synchronization.

We added additional logging and moved the synchronization to a completely separate server.
With that, we identified a couple of issues that made the synchronization fail.
One of these issues concerns "recurring events", so we had to disable synchronization of "recurring events" for now.
For most users, the other issues should be resolved and the synchronization is running automatically again.

We are looking into the remaining issues, but because of the better logging, we should be able to resolve these quicker.
The "recurring events" issue is also under further investigation.
Posted Nov 21, 2016 - 10:46 CET
Investigating
The syncing problem is narrowed down to only a handful of users.

Automatic synchronization is therefore disabled to be able to investigate those issues more thoroughly.
Manual synchronization of your calendar (with the syncing button on your calendar) should be possible.

In case of a problem, feel free to contact our support desk.
Posted Nov 08, 2016 - 11:37 CET
Identified
We've identiefied the problem and are fixing it right now.
Posted Nov 02, 2016 - 10:08 CET
Investigating
We're seeing problems with the synchronisation of Microsoft Exchange Web Services & Office 365 and Teamleader. We're working hard on solving the problem.
Posted Nov 02, 2016 - 09:18 CET