Teamleader slowness
Incident Report for Teamleader
Resolved
We have monitored the issue for the entire night and we can see that the issue is completely fixed.
If you would still encounter any issues please contact us via support@teamleader.eu
Thank you for your patience.
Posted May 05, 2020 - 08:56 CEST
Monitoring
We were able to fix the issue for now.
We will further monitor the situation and investigate the root cause.
Thank you for your patience and sorry for the inconvenience.
Posted May 04, 2020 - 11:14 CEST
Investigating
We are noticing that Teamlader is working slow. We are working on a solution as quickly as possible.
Thank you for bearing with us and we are sorry for the inconvenience.
Posted May 04, 2020 - 11:05 CEST
This incident affected: Teamleader Focus Web App.