Wrong date format on timetracking
Incident Report for Teamleader
Resolved
We have completely fixed the issue. Unfortunately, some accounts have some entries that are still saved on January 1st, 1970. If needed, you can manually put these back on the correct date. To find the wrongly tracked entries, you can click the link below and edit them for yourself or (as an admin) for any member of your team.

https://app.teamleader.eu/timesheets.php?view=day&year=1970&month=01&day=01

Affected users will be contacted via email as well.

We offer our sincerest apologies and hope you continue to enjoy using Teamleader.
If you have any questions whatsoever, do not hesitate to contact us via support@teamleader.eu.
Posted Sep 10, 2018 - 17:19 CEST
Update
We have resolved the issue. All new timetracking will be entered correctly again. Currently we're working on a solution to fix the data that was saved incorrectly, so all timetrackings from the past hours will be listed correctly again in the timesheets.
Posted Sep 10, 2018 - 12:27 CEST
Identified
We have identified the issue and are currently in the process of implementing a solution. We will keep you updated when the solution is live.
Posted Sep 10, 2018 - 11:26 CEST
Investigating
When tracking time on a task that you do not immediately finish, the date format on the timetracking will state it was tracked in 1970 instead of today's date. We are currently investigating this issue and we will back with a fix shortly. Thank you for your patience.
Posted Sep 10, 2018 - 10:38 CEST
This incident affected: Teamleader Focus Web App.