Pop-ups not working in Safari and Firefox
Incident Report for Teamleader
Resolved
The issue with the pop-ups has been resolved.
We apologise for the inconvenience this might have caused.
Posted Jul 18, 2017 - 12:33 CEST
Investigating
We are currently experiencing some issues with pop-ups in Safari and Firefox.
We advise our customers to work with Google Chrome.
We are working on a solution.
Posted Jul 18, 2017 - 11:40 CEST