Extraordinary Load
Incident Report for Teamleader
Resolved
This incident has been resolved.
Posted Jan 09, 2017 - 19:11 CET
Identified
We've identified the issue and stabilized the application.We'll be further investigating the issue
Posted Jan 09, 2017 - 16:16 CET
Investigating
We experience an extraordinary load which is causing server failure.
We are investigating the issue.
Posted Jan 09, 2017 - 15:58 CET