'Save' button unresponsive
Incident Report for Teamleader
Resolved
We fixed the 'Save' button issue. If this is still occurring for your account, clearing your cache should fix this entirely. You can read how to clear your cache on this website: https://www.lifewire.com/how-to-clear-cache-2617980
Posted Jan 10, 2018 - 16:00 CET
Identified
We're noticing a problem with all 'save' buttons in Teamleader. When clicking it, nothing happens. However, if you refresh the page, the information is updated. We're fixing this problem as we speak!
Posted Jan 10, 2018 - 14:42 CET