Invoices & reminders not sent out automatically in certain cases
Incident Report for Teamleader
Postmortem

Dear customer,

We would like to inform you that since February 16th there was a problem with the automated sending of invoices and reminders. Due to this issue, some invoices and reminders were not sent out automatically.

In the meantime, this issue has been completely resolved and measures have been taken to prevent similar problems in the future.

What should you do?

There is no further action required from your part. We have made sure that:

  • All booked invoices were sent out
  • All reminders were sent out
  • Invoices or reminders that you already sent out manually were not sent out twice to the same customer.

We truly apologise for any inconvenience this might have caused you. At Teamleader we strive to communicate open and honestly. We hope that we still can count on your trust and we want to thank you for your support.

Kindest regards,

The Teamleader-team

Posted Feb 26, 2018 - 10:26 CET

Resolved
The issue with invoices and reminders not being sent out in very rare cases has been resolved. All affected customers have been notified. We have made sure everything that was not sent out manually has been sent out automatically again.
Posted Feb 26, 2018 - 10:23 CET
Identified
We've identified the issue with the invoices and reminders. We're currently fixing the problem and we will be back with more news about possible necessary steps.
Posted Feb 20, 2018 - 19:54 CET
Investigating
We are currently investigating an issue with the automatic sending of invoices and reminders. We've noticed that in a few exceptional cases the invoices and reminders were not automatically sent out. Because this only happened in very rare circumstances and with very few customers, we are still investigating the cause. If you have experienced any problems, please contact us via support@teamleader.eu. Your help is very much appreciated!
Posted Feb 20, 2018 - 16:54 CET