Performance issue
Incident Report for Teamleader
Resolved
Thanks to a quick intervention of our engineering team, Teamleader is already back up and running to its normal speed. Thanks to you for hanging in there and thanks to our team!
Posted Apr 10, 2018 - 15:48 CEST
Investigating
We're noticing a delay in response time of the Teamleader web application. Our team is aware and investigating the issue. We'll be back shortly with more news.
Posted Apr 10, 2018 - 15:45 CEST