Pop-up loading issue on Internet Explorer 11
Incident Report for Teamleader
Resolved
The issue with the ever-loading pop-ups in Teamleader for users on the Internet Explorer 11 browser is resolved. All behaviour is back to normal. However, for the best Teamleader experience, we still recommend to use Google Chrome.
Posted Dec 13, 2017 - 15:40 CET
Investigating
We've noticed that loading a pop-up (creating a contact, company...) in Internet Explorer 11 is currently causing some issues. The pop-ups keep on loading endlessly. We're investigating the problem and looking for a solution. In the meantime, we advise to use Google Chrome or any other browser except Internet Explorer 11.
Posted Dec 13, 2017 - 09:50 CET