Degraded performance
Incident Report for Teamleader
Resolved
We haven't noticed anything unusual anymore.
If you however still experience issues, feel free to contact our support team.
Again, we're sorry for the inconvenience.
Posted Jan 08, 2018 - 13:47 CET
Monitoring
We've identified the cause. Everything should be back to normal, but we're keeping an eye on the situation.
If you still experience issues, feel free to contact our support team.
We're sorry for the inconvenience.
Posted Jan 08, 2018 - 12:34 CET
Investigating
We're investigating the cause of the problem and are doing everything we can to fix it ASAP. Visit http://status.teamleader.eu for updates.
Posted Jan 08, 2018 - 10:53 CET